Custom ROM for Xperia X10i – Better Than The Shipped One + Upgraded to Froyo(2.2)

| June 22, 2011 | 2 Comments

FreeX10 Froyo 2.2.1 AOSP ROM

Developed by zdzihu, xda-developer. The Fast and clean rom for sony ericsson xperia x10 is now available with froyo upgrade. The genius has made it possible to upgrade x10 from 2.1 to 2.2(which is, officially, yet NOT available from Sony Ericsson). god know when they will launch 2.3.3 update. if they’ll launch it will be slower ;)

[ad code=2 align=center]


You can install it directly on your mobile without PC. All you need is busybox and xRecovery installed on your mobile. Download the files needed.

Installation Instruction: DO NOT REINSTALL BUSYBOX OR XRECOVERY!YOU WILL END UP IN ENDLESS FC LOOP (AND BREAK XRECOVERY)!

1. Make sure you have android 2.1+ on your X10.
2. Root your phone if it´s not rooted! See this post for How-To!
3. Install xRecovery if you don´t have it already.
4. Copy following files to the root of your sdcard:
FreeX10-beta3.zip
gapps_1901_FreeX10.zip

FreeX10-beta4-hotfix2.zip

5. Reboot your phone and keep pressing the back button till you enter xRecovery.
6. Go to “Backup and restore” and make a backup of your current system.
7. Then select “Install custom zip” and browse for FreeX10-beta3.zip
8. Then again select “Install custom zip” and browse for gapps_1901_FreeX10.zip
9. Reboot your phone and wait for it to get signal after some automatic reboots!
10. If you are updating from Beta1 or Beta2 and want to restore your data then go to “Backup & Restore” in recovery, select “Advanced restore”, Select your Beta1 or Beta2 backup and restore “DATA” only!
It´s not recommended to restore data from 2.1!

Make sure that you have 2.1 updated device and has dual-touch(pinch zoom)

 

Install FreeX10-beta3.zip first, then gapps_1901_FreeX10.zip and then FreeX10-beta4-hotfix2.zip and reboot your phone. it will reboot your phone twice, let it be. its normal. from XDA-Developers

[ad code=4 align=center]

 

Tags: , , , , , , , , , , , , , , ,

Category: Android, Mobile, Mobile Phones

Anil

About the Author ()

Anil Sardiwal is a tech blogger at TheOnlyAnil.com and WideFide. Follow me on twitter @TheOnlyAnil or Join my WideFide @ Facebook

Short Bio - MBA Aspirant • Nature Lover • Tech savvy • INDIAN • likes Football & Badminton • Music and Movie Buff • Blogger • Student
  • Thamees

    is it important that we must have 2.1 updated and has dual touch pinch zoom?what if not?

    • http://theonlyanil.com/ Anil Sardiwal

      Yes, it is mandatory to have 2.1 update and pinch zoom, because they have
      latest baseband.